Kindle app immediately skips to end of video (need help reproducing!)



  • Hey guys! I would like your help reproducing an issue. Some of you have reported that the FunimationNow app video player immediately skips to the end when you try to watch any video on a Kindle Fire HDX. I have been unable to reproduce this issue on my own Kindle Fire HDX 8.9 (4th Generation) on Fire OS 5.1.1. In order to report this issue to our developers and get this fixed, I need more information to help them reproduce.

    If you are experiencing this issue please provide the below:

    Kindle Model:
    Fire OS:
    FunimationNow Version (located in Help > About):
    Your Access Level (SubPass or All-AccessPass):
    Video you tested with even if it happens on all videos:
    Your audio preference setting:
    The language you attempted to watch the video in:

    If you are NOT experiencing this exact issue, please post over here: http://www.funimation.com/forum/showthread.php?10223-FunimationNow-mobile-app-is-available-NOW!

    [Update]

    Our developers were able to reproduce the issue and have opened a ticket with the app video player's SDK vendor. I'll update as I receive more information.

    Thank you!



  • Kindle Model: Fire HDX (3rd generation)
    Fire OS: 4.5.5.1
    FunimationNow Version (located in Help > About): 1.0.1
    Your Access Level (SubPass or All-AccessPass): All-AccessPass
    Video you tested with even if it happens on all videos: Dimension W - The Possibillities of the Dead
    Your audio preference setting: English
    The language you attempted to watch the video in: Just hit play, but it said it was English

    The new build of the Kindle app has never worked right for me, so I generally use my iOS devices if I am mobile.



  • Sorry for the late reply was at Disney on vacation with my kids.
    Seems that both of us have the same kindle hopefully that might help you guys figure out the issue

    Kindle Model: Kindle Fire HDX (3rd Generation)
    Fire OS: 4.5.5.1
    FunimationNow Version (located in Help > About): 1.01 (I found this in my application settings I didnt see anywhere in the help that showed it
    Your Access Level (SubPass or All-AccessPass): All-Access
    Video you tested with even if it happens on all videos: Fairy Tail 116
    Your audio preference setting: curently English (I have flipped this back and forth to see if it made a difference)
    The language you attempted to watch the video in: same as quertermous as far as I can tell there is no way to know what language you are playing in since you cant actually watch any of the episode and I do not see any label that tells you what is currently playing

    The kindle app has never worked for me at all, my android phone app works (albeit with more buffering than it used to but that may be connection based)



  • I just did a "contact support" through the app for this exact issue, but ill post here too. Here's what the support email autofilled:
    App Name: FunimationNow
    Version: 1.0.1
    Device: Amazon KFAPWI
    OS: 4.4.3
    Connection: Wifi
    Carrier: Unknown

    However my kindle is on 4.5.5.1 not 4.4.3.
    It is a model 8.9 gen 3 kindle fire hdx.
    Lastly I have tried a bunch of the newest simulcast with the same results: Kumamiko episode 3, Three Leaves, Three Colors episode 2, My Hero Academia episode 3, One Piece episode 737, and endride episode 3 to name a few. Obviously these are all subbed. For fun I tried episode 1 of spice and wolf in both English and Japanese with the same result.

    Please let me know if there's anything else I can do to help!!! Hopefully the new app is fixed before the old one goes away.

    Oh forgot to add, I have an all access pass an d my language preference is English.



  • Thank you!!

    It looks like all of you experiencing this issue are all on Android 4.5.5, so I'll go ahead and report the issue now. Are any of you able to/do any of you want to update to Android 5? If so, could you please test again and see if the issue still happens?



  • @Sophie:

    Thank you!!

    It looks like all of you experiencing this issue are all on Android 4.5.5, so I'll go ahead and report the issue now. Are any of you able to/do any of you want to update to Android 5? If so, could you please test again and see if the issue still happens?

    I thought of doing that actually. OS updates are managed by Amazon and when you search for updates from the device it says you are on the current version. I will do a little more research but I'm not sure if we are able to upgrade to 5.x on the 3rd gen HDX's.

    I actually just replaced mine (after an unfortunate water incident). I thought about upgrading but found out the 3rd gen HDX's are actually far better (faster processor and higher resolution) than the current generation so I bought another 3rd gen.

    edit:
    Just went real quick to the Amazon forums and I'm only marginally less confused lol. It appears that OS 5 was only released for 2014 (gen 4) and above. There are many pages of back and forth about if it will ever be released for gen 3. The final post in the thread is from a user who said an Amazon rep told them mid 2nd quarter 2016 for the OS 5 update for gen 3. The whole thread is literally about 50/50 Yes you will get it / no you definitely will not, so I guess only time will tell..



  • Thank you for looking that up. I was suspecting that something like that would be the case. I've created the bug for the developers, so hopefully it will be fixed for you all very soon. I'm also updating the Known Issues list now that we have a bug in.



  • Thanks a lot for keeping us in the loop. Appreciate it. Here's to hoping for a speedy resolution!



  • I just looked at the known issues thread and saw what you added. I just wanted to clarify the issue a bit. Videos do not play for more than about a half a second. It jumps to the end and freezes. The way its worded in the bug thread seems to imply that the video plays but only after 24:20 (not ALL episodes end at 24:20). I have been unable to get any video to play for more than a second at any point in any episode (if you tap the middle of an episode it will load, play about 5 frames and then the bar skips to the end and video freezes). I don't think you need to update the description of the bug but I just want to make sure the guys fixing it are looking for the right thing.



  • Thank you for clarifying. In the bug I reported to developers, I said "It skips to the end". I'll also revise on the known issues list.



  • I have a KindleFire HDX (gen 3) and am having the same issues. My husband has a new KindleFire and can play the Funimation app without any problems. I would LOVE to be able to play anime on mine. Is there / will there be any resolution to this problem? I have tried deleting and reloading several times, and each time it seems to load just fine, shows the start up sequence and our queue but as soon as I start a show it freezes after a second and will not play at all.



  • Bummed out the old app stopped working. Crossing my fingers this gets fixed soon.



  • The old app is done, you're going to have to use the new app or the website now.



  • I meant I hope the bug gets fixed soon so I can use the new app. I travel for work with just my kindle and I'm itching to get my fix haha.



  • Yes, I hope it is fixed soon too - I was watching anime on my lunch hour. The old app was limited but at least it worked!


Log in to reply