Roku channel displays 2-4 episodes to subscribers - RESOLVED



  • We are currently working to fix an issue where the Roku channel is only displaying the first 2-4 episodes of every show to subscribers as a result of the latest site update. Please do not submit a ticket. Sit tight. We'll have it fixed in jiffy.

    Thank you to all who have submitted tickets already, as that alerted us to the issue almost immediately. I'm going to leave this thread open in case users would like to report anything else weird going on or if it has been fixed. I'll also post any other steps you may need to take such as restarting your Roku.



  • We believe this issue to be resolved. Please post to this thread if you are still experiencing issues.



  • Confirmed the fix on my own Roku (finally). Seems that my Roku decided to stop loading all my channels suddenly and then change all the channels on the Home screen to question marks, and I had to stop to try and fix that once I had confirmed that it wasn't only our channel. So, I was lucky and two issues - one that was ours and one that was my Roku.

    All users should have the correct access now based on their subscription level. If you are an All-AccessPass or SubPass subscriber, please try logging out and back in to the Roku channel. You must do this from inside the channel by going to Settings and then by selecting "Log out". Then you can log in by using… wait for it... your username OR your email address. You should then have access to all available content and TV-MA content assuming you are at least 17-years-old.

    If logging out and back in does not work, please try exiting the channel and relaunching. If that does not work, please clear your Roku's app cache by unplugging it, waiting 10 seconds, and then by plugging it back in.

    If THAT doesn't work, please email roku (a) funimation dot com. I am the Roku Support Tech, so I will be working with you.

    FWIW, if anyone else experiences what I did on a Roku - all channels crash then eventually only display large question marks. Go to the secret screen Home x 5, FFW x 3, RW x 2. Then choose "Update software". At first, I got a network error, so I reset my router by unplugging it and plugging it back in. Then I chose "Update software" again and this time it took. Then I went back to Roku Home and then to System. Then I chose to update my software to reload all my channels.

    Phew.

    You know, in case you were curious. I just thought I'd over share.



  • As we haven't had any new tickets about this issue all day, I think it's safe to say this issue is closed.

    Locking thread.


Log in to reply