[RESOLVED] Unable to restart subscription



  • Any time I try to "place order", I get an odd error that reads:

    "The credit card on file for this account is not valid or does not have enough funds to complete this purchase. Please enter a valid credit card number. "

    The only card I have on file is valid (was just issued two weeks ago) and I have plenty of funds on account. As a work around, I tried entering a different credit card and after saving, I get an error as if I tried submitting/saving a new card without filling out the required fields.

    I've attempted submit a ticket to support using the "Contact Us" forum, however. Any time I try to submit that, I get "Submission Error. Please try again."

    So, I'm pretty dead in the water. Not sure what the deal is, but I was able to update all my information a couple weeks ago when the new site went live. Since then, it's been riddled with these issues and I've been trying to restart my subscription and submit a support form for weeks now with no luck and nothing, but these errors.

    If anyone else has experienced this and found a work around, it would be much appreciated.

    Thank you



  • I'm sorry you're having issues. Let me contact @FunimationHelp on your behalf and let's see if they can help you out.

    EDIT: The guys at FunimationHelp suggested that you try emailing help@funimation.com directly. They took a look at your account and noted that it wasn't being affected by any known issues that they were aware of.



  • @SpacemanHardy I appreciate the helping hand.

    As of 10pm PST last night, I was still unable to log in or reset my password (all resulted in the same errors as reported before)

    This morning at 7am PST, I was finally able to login and restart my subscription.

    Between that time, Support had reached out to me via email and said the same thing (no issues could be found with my account) and suggested I try subscribing again. The problem, at that time, was I couldn't log into my account. It would appear that something got "fixed" or there was something on their end that was eventually resolved.

    Either way, all appears to be good now.



  • As things are resolved here, I'm going to lock up the thread.


Log in to reply