Post window with similar organization/ functionality to Microsoft Word.



  • 0_1500798457526_Revised post window.JPG



  • Bold and italic work by just selecting the text then clicking the button, I've been doing it that way since the new website is online (it just adds the astericks automatically).



  • Hello once again Krock,

    Basically if i type the word "test", select it, then hit the B for bold, the following is what happens:
    0_1500882841743_inconsistency with formatting.JPG

    It does not bold the word "test" only displays the wording of "bolded text" bolded, if that makes sense. Basically, unless my text falls inside the asterisks it does not work. The way i see it, you should be able to select your text, hit either Bold or Italic and it should Bold or Italic the specific word, not present jargon of "bolded text" and then, your word still not bolded.

    Sincerely,
    P.J.



  • test

    Operator error, then. Highlight the word first.

    you should be able to select your text, hit either Bold or Italic and it should Bold or Italic the specific word

    Like this. Complicated.



  • Nobu from out of nowhere! (laughs) ;-)

    How have you been?

    Believe it or not, in the example, i did select/ highlight the text first then i chose the "B" for bold and that screenshot presents what i'm seeing from my end. Like i said a moment ago, i have to place my text "just right" inside the asterisks for it to work - - which is not really optimal. I shouldn't have to "jump for joy" (laughs). You should be able to highlight your text, select Bold or Italic and it should convert the text, not display that odd presentation that you can clearly see evidenced in my screenshot.

    Sincerely,
    P.J.



  • I'm well, thank you. :-)

    i did select/ highlight the text first then i chose the "B" for bold and that screenshot presents what i'm seeing from my end.
    .
    .
    .
    You should be able to highlight your text, select Bold or Italic and it should convert the text, not display that odd presentation that you can clearly see evidenced in my screenshot.

    Sounds like you missed, and got that result.



  • Hi Nobu,

    Okay. If i select "Bold" first, then type, it will work, however, then i have to move the cursor outside of the asterisks as it will continue to bold. I don't know, overall, for something that you shouldn't have to think twice on, seems like the nodebb platform adds a bit of convolutedness? For example, when i'm on Norton's community forum, i don't run into any of these oddities...

    Sincerely,
    P.J.



  • @P.J. said in Post window with similar organization/ functionality to Microsoft Word.:

    If i select "Bold" first, then type, it will work, however, then i have to move the cursor outside of the asterisks as it will continue to bold.

    That works as it should, as well. I'm referring to:
    test <-- 1) type the word or phrase.

             2) Select the word or phrase with the cursor.
    

    test <-- 3) click the button.

    0_1500886957845_text button.png

    Don't ask me how step 2 happened.



  • YaY! {:-D I get to see Nobu's desktop

    Perhaps there are these differences because you are viewing with Chrome?



  • @P-J Just like @Nobu said, it should already behave as expected, I suspect a bug with the browser you're using, which is Edge / IE if I'm not mistaken?



  • test

    testbolded text

    testitalicised text

    teststrikethrough text

    0_1500893761613_explorer text.png

    @the_krock said:

    I suspect a bug with the browser you're using, which is Edge / IE if I'm not mistaken?

    Must be it (IE). Edge behaves normally, but I can't directly upload a picture. Or apparently use imgur correctly.



  • Or apparently use imgur correctly.

    http://imgur.com/DmToZon


Log in to reply