Subtitles/Language options not working/disappearing?



  • So, I have been subscribed to Funimation for quite awhile even though I only had used it once, I stayed subscribed just to support the site. When I initially subscribed I didn't have any problems, but recently I came back after months of not using to watch Eureka Seven since it isn't on CR. I didn't have any problems until I got the episode 37.

    After watching a few episodes, randomly the next one didn't have an option for subtitles. It was just gone. I could watch in both languages but both didn't offer subs. This was JUST after watching an without issue. I figured okay, whatever, must be a bug. Except after trying almost daily for about 2 weeks it was never fixed so I gave up. Then after a couple weeks I come back to watch Seraph of the End, and, to my surprise it worked... for the first 10 episodes. Now i'm back to having issues. I've been trying daily and about 1 times out of 5 it works. This is on both a browser and the Android app.

    I've had English ONLY, English and Jap but no subtitles(what I have as i'm trying this), English and Jap but only subtitles available when I switch to English, but only 1 day out of 5, maybe less, do I get a functional streaming service.

    Like anyone who's waited patiently with no fix for over a month, I sent in a ticket to customer service. This was probably 3-4 weeks ago, I never got a response. So about a week ago, I sent another and again, no response. So I come to the forums where (which by the way has so search option I could find so I couldn't even see if this problem has been brought up) I'm desperately hoping that there is a fix for this. Not get a response from customer service did push me over the edge a bit and I have since cancelled my subscription but will consider a re-sub if this is fixed.

    I get that Funimation is mainly dubs and physical merch/content but ffs if your going to have exclusives and charge a monthly fee for them at least let me watch them.
    Sorry for the long post and if I posted in the wrong area but the no response from customer service has been EATING AT ME.



  • Hi @caseyyalan

    Looks like Eureka Seven episode 37 is a bug revealed by a content issue. This episode does have an active US Japanese avail, but it also has an expired US Japanese avail. I have noted the bug to be looked at. Episode 38 only has 1 active SVOD Japanese avail and 1 active AVOD Japanese avail, so that's why that one worked.

    The reason you are getting mixed results is likely because some episodes don't have these extra inactive avails and some do.

    Your first ticket, submitted on June 16, was responded to on June 29. It looks like Customer Service had some questions. Please check your email. Your second ticket, submitted on July 1, has not received a response from Customer Service yet.

    Forum search is here, by the way:
    0_1499270295490_2017-07-05_1039.png



  • @Sophie thank you for the response, I did find the customer service response. I also get that an episode or episodes could be bugged but the same episodes are having the issue. Like, if I try to watch Eureka Seven episodes 1-36, I get the same problem that I do on 37. Also, atm I'm trying to watch Seraph of the End ep.15 but the only option for languages is English. This goes for EVERY show I try watching. I just picked about 10 different shows and clicked the first episode and had the same results, only English. If on another day, when I try and watch my show and it works, I will try doing the same thing and see if it works for every show or not.



  • If you find more, could you please post a few examples here, so I can see if there is a pattern? What I posted earlier is only what I think could be the issue.

    So on Eureka Seven 1-36, you can't watch them in Japanese at all or is it that you can't display the subtitles?



  • I'm having the same issue on Seraph of the End! For me it was episode 8 and now 23. Episode 9 as well, it played the first half in Japanese with subs and then I got interrupted and came back later to find the same episode suddenly lost its subtitles option. English captions work when streaming in English--this seems to be limited to Japanese streaming. This is also not limited to a single device, it happens on the iPad, iPhone, web browser(safari), and Apple TV. I've been able to get around it every once in a while by switching from simulcast to uncut but it is not a fix. I've also tried deleting/re downloading the app. Please let me know if there is a solution! Or maybe add subs as a default setting like you can for language preference. It's really troublesome to have to turn it on every single time. Thanks!



  • Wait, so the Japanese subtitles disappeared during the episode?



  • Not while I was watching it. I had started it and got about ten minutes in, and it was working fine but when I re opened the app later in the day it started playing where I had left off but subs were no longer available. It's so weird :S



  • Eureka Seven is already on crunchyroll. All 50 episodes except for the movie.

    And some shows that are English dubbed in funimation will be on crunchyroll.



  • Yeah so...just happened on Tokyo Ravens too. Maybe the app needs an update?



  • @Kurosakigirl
    I think it's because the app is having you resume in a version that doesn't have soft subtitles instead of the version you last watched. Seraph of the End Simulcast version episodes are missing srt files, but they are working on the Uncut version episodes. The same goes for Tokyo Ravens. I have reported Seraph of the End and Tokyo Ravens to be fixed.



  • Awesome, thanks for your help!



  • Hi, I am having this same problem. Didn't use the streaming service for a couple months and tried to get back to watching Durarara!!, but the subtitles are not working. I am on episode 8. @Sophie


Log in to reply