Roku - Episode starts to load, but then goes back to previous screen (RESOLVABLE)



  • I've started to see a few reports of an issue where the user tries to play a video, the screen with the loading bar at the bottom displays and begins to load for 1-2 seconds, but then goes back to the previous screen instead of playing the episode.

    In order to reproduce and further diagnose this issue, I need some help. If you have experienced this issue, please send an email to roku@funimation.com with the following information:
    1. Roku diagnostic logs taken while experiencing this issue. Please see instructions in post #7 in this thread on how to create and download diagnostic logs from your Roku.
    2. Your Roku's IP address. Roku Settings โ€“> Player Info --> IP address
    3. Your ISP (Internet Service Provider)
    4. Your general location (Houston, TX, for example)
    5. The date and the approximate time of day you experienced the issue. If you experience it all the time, please give us one time, as accurate as you can make it.

    Thank you!

    Please note that Eureka 7 dub exhibits this exact behavior, but the error being returned is actually a 404 instead of a 500 if you look through the Roku diagnostic log. These episodes actually aren't supposed to be available and the error means that there is a small bug in the feed. Please do not use Eureka 7 to test the issue that is being tracked in this thread.

    [line][/line]

    Update 1/27/2014:
    It looks like this issue is related to the video player buffering issue that we're tracking in this thread: http://www.funimation.com/forum/showthread.php?778-Buffering-Issues

    Please see the new instructions for reporting information to help us resolve this issue. Please only email the above information to roku@funimation.com.

    Update 1/28/2014:
    Possible cause has been found and issue may have been resolved! Update containing fix will be available on or before January 31, 2014 from the Roku Channel Store. ^_^

    Update 1/31/2014:
    Update is ready! :) Once you have the channel updated, please try to watch some of the episodes that you could not watch before and let me know if you are or are not able to play them now.

    To update, you can either:
    1. Remove the channel and then re-install from the Roku Channel Store.
    OR
    2. From the Roku menu, select "Settings", then select "System update".
    OR
    3. From the Roku menu, select "Search", then enter "FUNimation", and then select it and "Add Channel"

    Update 2/3/2014:
    I've had a couple reports that some users are still experiencing this issue. Please create logs and send them to roku@funimation.com while you are experiencing the issue. The steps for creating a log can be found in post #7 of this thread. The logs contain error messaging that is critical to diagnosing the issue and are especially important since I have never been able to recreate it on either of my Rokus.

    Update 3/6/2014:
    This issue has a few causes. Because we've fixed a 500 error issue that was occurring thanks to everyone's logs, if you are still experiencing this behavior, then it is most likely related to your Roku's available memory and is not an issue with the FUNimation Roku Channel.

    If you have more than 20 channels installed on your Roku, please try removing some until video playback works again on the FUNimation Roku channel. Each Roku has a different channel capacity. The newer your Roku, the more space it has for channels. You could have up to 40 channels before experiencing this behavior on some Roku models. If your Roku has an SD card slot, then you can use an SD card to improve your Roku's channel capacity.



  • My brother just went through the top row of "featured" shows. I tried to play the first and last of both the subtitled and dubbed episodes. I literally cannot find a single episode of any anime that works.

    And just so you don't delete the post even though this info is included above . . .

    Show Title: Fairy Tail
    Episode #: 1
    Language (Sub or Dub): Subbed AND Dubbed
    Quality (SD or HD): HD AND SD
    Time Attempted to Watch: 10:50 a.m. CT

    I hope you find this helpful.



  • Thank you for filling out the form. The reason I ask for it is so that people don't just respond with "It happens with everything I try to watch." Unfortunately, that information, while very much appreciated, is still a bit too vague for me to work with. If I try to play just any episode at just any time while testing and am able to play it through just fine, then I have to conclude that the issue is no longer occurring based on the information provided. The form gives me testing parameters and tells me what to do in order to reproduce consistently. "Consistently" is the key word here because if I tell the developer that the issue is "random", they will test once, see that it happens to be working at that moment, and conclude just as I did that the issue is no longer occurring and will stop work on it.

    Thanks again!



  • I'm getting this problem most of the time when I go to start a video, just not every time. It fails pretty quickly, so I'm able to just spam the "watch episode" option and it'll come up maybe one every six times? Sometimes instead of just failing back onto the previous screen, it shows a little window that says "checking connection" before taking me back to the previous screen.

    I'm on Roku 2 XD and I ran the software update before testing it by jamming the button, and it isn't letting me update anymore, says it on 5.3 build 3063. Deleted and reinstalled the funimation app, power cycled by unplugging and replugging the power cable. The first episode I went to load after power cycling worked, which made me think maybe it was okay now?, but the next one didn't.

    I'm an elite subscriber and otherwise it's working as it should, everything shows up along with HD options.

    Here's one that isn't working for me most of the times I go to load it, but does work sometimes.

    Show Title: Big Windup
    Episode #: 7
    Language (Sub or Dub): Subbed
    Quality (SD or HD): SD
    Time Attempted to Watch: 3:40 pm

    I've tried this on other videos too.

    If there's anything else you want me to test please let me know!



  • Thank you for update. I've been unable to reproduce the issue on my Roku, but I have an LT. Perhaps it is the model then.

    I have encountered a "checking connection" message while watching Netflix. The issue usually occurs in the evening during which I assume are peak hours. Usually, it's been caused by my Roku dropping the connection to my router. So far, I've been able to just restart the episode.

    This leads me to believe that the issue might be caused by a connection issue - either on the server side or the user side. I don't think model is related, but I don't want to rule that out quite yet.



  • Update: Float Left has been notified about this issue. I have given them all information that I have received from users. Unfortunately, I am still unable to reproduce the issue, but my new Roku 2 XD has arrived. I will test this issue on it tonight. ^_^

    Also, I am very excited to be able to stream in 1080p.



  • I tried watching some of the videos reported on my new Roku 2 XD. I was able to play everything, (unfortunately?), so I still haven't been able to reproduce this issue. However, I did find some other things to try that could help us diagnose what is going on.

    Things to try next:
    1. If you haven't already done this, please perform a factory set by pushing the button in the small hole on the back of the Roku with a paperclip. This will actually reset your Roku and force you to reconnect it to your Roku account. Then load up the FUNimation channel, log into your account, and try to play an episode. If the episode does not play, then move on to step 2.

    2. Go to the secret Playback Debug menu. Exit to the home screen. Then on the remote, push Home 5 times, then Rewind 3 times, and then Forward 2 times. Then choose "Enable Playback Debugging". Then load up the FUNimation channel and try to play an episode. A message should appear once the video loads. If playback is successful, this message will be something like "Playing 1.5 mbps stream on your 9.1 mbps network". I'm hoping that the message will be different if playback is unsuccessful. If that doesn't work, then please move on to step 3.

    3. First, go to the Developer Settings secret menu and enable developer mode. From the Roku Home screen, push Home 3 times, then Up 2 times, then Right, Left, Right, Left, Right. On the screen that appears, select "Enable installer and restart". When the Roku is back online and on the Home screen, go to the Debug menu. Push Home 5 times, Fast Foward 3 times, then Rewind 3 times. Select "Enable Debug Logging". Then load up the FUNimation channel and try to play an episode. Then exit the channel and download the debug logs. You can download the logs (called log0, log1โ€ฆ etc) to your computer at http://roku-ip-address/pkgs. Your Roku ip address and username are listed on the Developer Settings page. Then email the logs to roku@funimation.com.

    Thank you!



  • We pushed a new build on 1/13/2014. Please update the FUNimation Roku channel by removing it and reinstalling it from the Roku Channel Store. Alternatively, you can remove it and then search for "FUNimation" from the main Roku Search. This build should only fix the authentication issue we had, but maybe it will also do something for those of you affected by this playback issue.

    Also, thank you for the logs sent so far. I noticed a few errors in them, which should be of great help to Float Left!



  • I'm sending you the logs for my problem which seems to correlate to this problem.



  • Awesome! Thank you. I'm seeing a pattern between yours and the other log. Still no ETA on fix, but we are another step closer.

    Also, could you please test some of the same episodes on the website and let me know if you are able to play them? I'm wondering if this is an IP/territory issue occurring on the Roku and Roku just doesn't have the error reporting message for this error.



  • I have an update on this issue. Could all affected users please try watching the episodes on the website that they tried to watch on the Roku? Because both the Roku and the website use the same source videos, the website might give us more insight into the issue.

    Thank you!



  • Yes, I can watch videos on the website just fine. Just checked again today and still have problems with Roku viewing though.

    Thanks for your help and can you keep us updated here with an ETA? Thanks!!!



  • No problem. Thank you for testing. I update this thread as I get more information. Unfortunately, I still do not have an ETA. However, I can add dates to my updates to the OP so that you at least know when the last check for an update was made.



  • Same here. Any video I try from the website works just fine. No videos I try on the Roku work.



  • At least we have consistency then. Thanks!



  • I don't know about anyone else, but it is working for me now!



  • Still not working for me :(



  • Interesting. Thank you for following up. It seems as though this issue is related to the overall video buffering issue. For those of you affected, please see this thread: http://www.funimation.com/forum/showthread.php?778-Buffering-Issues

    I will update the OP with this new information as well.



  • I am having an issue today, started about 30 minutes ago, I was watching Fairy Tale ep 62, and it finished. I then went to play the next episode, and the Roku just kinda.. froze. I could back out of menus, but not go down levels.

    I was still in the fairy tale selection, and had hit the play button, and just let it sit. After maybe 10 minutes or so, it finally prompted me to select what definition I wanted, and then hung again. I then proceeded to uninstall and reinstall the app, and it did the same things again. It does this for all videos I have tried so far.

    I have the roku 2 XD. It eventually loads my selections, but takes about 10 minutes in between. The screensaver functions normally, so I know the roku is doing fine, but the app is just being weird.



  • @skullriot - Please do not report issues in the forum or hijack existing threads with new issues. The OP of this thread describes the behavior of the issue that we are tracking and has what you should reply with. Any new issues should be reported to www.funimation.com/support. You may also email roku@funimation.com directly. I have a 24-hour response rate excluding weekends and holidays, currently.

    @skullriot:

    I am having an issue today, started about 30 minutes agoโ€ฆ

    Thank you for reporting. That issue was resolved at 10:00 a.m. An update that will prevent the specific cause of that issue from happening again will be pushed to the Roku Channel Store very soon. You should be good to go in the meantime, though.



  • I'm having something similar to that issue however mine just freezes on the opening image of the Funi app. it doesn't even switch over. I just tried to do a manual update of the roku and there were no updates is there a idea when the update will be? if it matters my Roku is a 2 XS. I'd love to be able to get back to one piece.


Log in to reply